Wired Repeater (to Lsn.)

Q: Will this manual be the same, if I want to add one more router? But the only difference would be that it would be connected to the main router by LAN cable. The rest is the same.

A:

If you want to add another router as a bridged repeater connected to the main router via a LAN cable, the steps will be similar but with some differences due to the wired connection. Here’s how to set it up using both the web interface and SSH:

Using the Web Interface

  1. Log in to the OpenWrt Web Interface:

    • Open a web browser and go to the IP address of your router (usually 192.168.1.1).
    • Log in using your username and password.
  2. Disable the DHCP Server on the Repeater Router:

    • Go to Network > Interfaces.
    • Click the Edit button next to the LAN interface.
    • Go to the DHCP Server tab and uncheck the Enable DHCP checkbox.
    • Save and apply the changes.
  3. Set a Static IP Address for the Repeater Router:

    • Go to Network > Interfaces.
    • Click the Edit button next to the LAN interface.
    • Set the IPv4 address to match the main network range but outside the DHCP range (e.g., 192.168.1.2 if the main router is 192.168.1.1).
    • Set the IPv4 gateway and DNS to the main router’s IP address (e.g., 192.168.1.1).
    • Save and apply the changes.
  4. Configure the Wi-Fi as an Access Point:

    • Go to Network > Wireless.
    • Click Add to create a new Wi-Fi network.
    • Set the mode to Access Point and use the same SSID and security settings as your main router.
    • Save and apply the changes.
  5. Connect the Router to the Main Router via LAN Cable:

    • Connect one of the LAN ports of the repeater router to one of the LAN ports of the main router using an Ethernet cable.
    • Do not use the WAN port on the repeater router.

Using SSH

  1. Connect to the Router via SSH:

    • Open a terminal and connect to the router:
      ssh root@192.168.1.1
      
  2. Disable the DHCP Server:

    • Edit the DHCP configuration file:
      vi /etc/config/dhcp
      
    • Find the section config dhcp 'lan' and set option ignore '1' to disable DHCP:
      config dhcp 'lan'
          option interface 'lan'
          option ignore '1'
      
    • Save and exit the editor (:wq in vi).
  3. Set a Static IP Address for the Repeater Router:

    • Edit the network configuration file:
      vi /etc/config/network
      
    • Modify the LAN interface to set a static IP address:
      config interface 'lan'
          option ifname 'eth0'
          option proto 'static'
          option ipaddr '192.168.1.2'
          option netmask '255.255.255.0'
          option gateway '192.168.1.1'
          option dns '192.168.1.1'
      
    • Save and exit the editor.
  4. Configure the Wi-Fi as an Access Point:

    • Edit the wireless configuration file:
      vi /etc/config/wireless
      
    • Add a new section to set up the access point:
      config wifi-iface
          option device 'radio0'
          option network 'lan'
          option mode 'ap'
          option ssid 'YourMainSSID'
          option encryption 'psk2'
          option key 'YourPassword'
      
    • Save and exit the editor.
  5. Restart the Network:

    • Restart the network services to apply the changes:
      /etc/init.d/network restart
      
  6. Connect the Router to the Main Router via LAN Cable:

    • Connect one of the LAN ports of the repeater router to one of the LAN ports of the main router using an Ethernet cable.
    • Do not use the WAN port on the repeater router.

Summary

By following these steps, you will have set up a second TP-Link TL-WR841N router as a wired bridged repeater. This setup will extend your main wireless network (SSID) and allow devices to obtain IP addresses from the main router’s DHCP server, enabling all devices to see each other. The primary differences from the wireless repeater setup are disabling the WAN port and connecting the routers via a LAN cable.